Tyro Service Status

Transaction processing system
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.
Posted May 09, 2021 - 21:30 AEST
Monitoring
We are aware that some customers between 8.01pm and 8.12pm may have experienced difficulty processing transactions.

Our systems have returned to normal however recommend customers reboot their terminal and contact our Australian based 24/7 Customer Support team on 1300 966 639 if any assistance is required.

We apologise for any inconvenience experienced.
Posted May 09, 2021 - 21:20 AEST
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted May 09, 2021 - 20:15 AEST
This incident affected: Transaction Processing Systems.