Tyro Service Status

Tyro Go app unavailable
Incident Report for Tyro Platform Service
Resolved
The issue is resolved, and customers should now be able to access the Tyro Go app.

We’re sorry for any inconvenience caused to you and your customers.
Posted Nov 22, 2022 - 11:56 AEDT
Monitoring
We’re aware of an issue with The Tyro Go app where customers are unable to log in.

We’re actively monitoring the situation and will provide updates as they become available.
Posted Nov 22, 2022 - 09:36 AEDT
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Nov 22, 2022 - 09:03 AEDT
This incident affected: Transaction Processing Systems.