Tyro Service Status

Direct Debit delay

Incident Report for Tyro Platform Service

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 13:23 AEDT

Investigating

Please note, for customers who are debited on the first of the month, there will be a few hours delay to their debit today. We apologise for any inconvenience experienced.
Posted Apr 01, 2025 - 11:36 AEDT