Tyro Service Status

Potential settlement delays
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved. We’re sorry for any inconvenience that was experienced.
Posted Jun 25, 2020 - 15:40 AEST
Monitoring
The earlier issue regarding delayed settlement which affected a small number of customers has now been resolved and all settlements have been processed.

Please note that the time your settlement funds appear in your account may be slightly later than normal.

We’re sorry for any inconvenience being experienced.
Posted Jun 24, 2020 - 16:39 AEST
Identified
We are currently experiencing issues which may affect the ability to process settlements for some customers.

We are currently investigating this issue and will provide further updates on this page as they become available.

We’re sorry for any inconvenience being experienced
Posted Jun 24, 2020 - 15:39 AEST
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jun 24, 2020 - 15:24 AEST
This incident affected: Settlement.