Tyro Service Status

Issue with Tyro Go and BYO transactions
Incident Report for Tyro Platform Service
Resolved
The issue impacting Tyro Go and BYO transactions is now resolved and our systems have returned to normal. We’re very sorry for any inconvenience caused.
Posted Nov 18, 2023 - 21:39 AEDT
Update
We’re currently experiencing an issue impacting some customers’ ability to process transactions on Tyro’s Go and BYO app.

The team are working to resolve this issue as quickly as possible, and we’ll continue to provide updates on our progress.

We’re sorry for any inconvenience being experienced
Posted Nov 18, 2023 - 20:24 AEDT
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Nov 18, 2023 - 19:52 AEDT
This incident affected: Tyro App.