Tyro Service Status

Issue processing some transactions
Incident Report for Tyro Platform Service
Resolved
Whilst outside of Tyro's control, the issue is now resolved, and our systems have returned to normal.
Posted Aug 06, 2022 - 20:24 AEST
Investigating
We are currently experiencing issues which may affect the ability to process transactions.

We're in the process of investigating and will provide further updates shortly.

In the meantime, please try an alternative payment method.
Posted Aug 06, 2022 - 19:59 AEST
This incident affected: Transaction Processing Systems.