Tyro Service Status

Issue processing some transactions
Incident Report for Tyro Platform Service
Resolved
This issue is now resolved. You should be able to process all transactions.

We’re sorry for any inconvenience experienced.
Posted Oct 20, 2020 - 10:53 AEDT
Identified
We are currently experiencing issues which may affect the ability to process some transactions. We're in the process of investigating this issue and will provide further updates on this page as they become available.

If you are experiencing difficulty in processing a transaction, please try using a different payment method.

We’re sorry for any inconvenience being experienced.
Posted Oct 20, 2020 - 09:46 AEDT
Investigating
We are currently experiencing issues which may affect the ability to process transactions.

We're in the process of investigating and will provide further updates shortly.

In the meantime, please try an alternative payment method.
Posted Oct 20, 2020 - 09:16 AEDT
This incident affected: Transaction Processing Systems.