Tyro Service Status

Settlement delay

Incident Report for Tyro Platform Service

Resolved

Some customers who settle into an external bank account will experience a delay to their payment today.

Whilst this issue was outside Tyro’s control, we understand and apologise for the inconvenience this may cause.
Posted Mar 01, 2026 - 10:19 AEDT

Investigating

We are currently investigating this issue.
Posted Mar 01, 2026 - 08:54 AEDT
This incident affected: Settlement.