Tyro Service Status

Pairing issues
Incident Report for Tyro Service Status for Customers
Resolved
The ability to pair terminals with some POS/PMS systems was temporarily unavailable.

This issue is now resolved.

We’re sorry for any inconvenience caused to our customers
Posted May 27, 2020 - 14:15 AEST
Monitoring
Update – a fix has been implemented and we are continuing to monitor the situation. We will provide an update upon confirmation the issue is resolved.

We’re sorry for any inconvenience being experienced
Posted May 27, 2020 - 11:24 AEST
Update
We are currently experiencing an issue with pairing our terminals with some POS/PMS systems.
We're in the process of investigating this issue and will provide further updates on this page as they become available.

We’re sorry for any inconvenience being experienced.
Posted May 27, 2020 - 10:24 AEST
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted May 27, 2020 - 10:01 AEST
This incident affected: POS Integration.