Tyro Service Status

Possible system issues

Incident Report for Tyro Platform Service

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 10:12 AEST

Monitoring

As a result of a reporting issue on Saturday, a small number of customers will experience a day's delay in settlements. If you haven't received your settlements as usual, please check again in 24 hours. We apologise for any inconvenience caused.
Posted Apr 05, 2025 - 23:46 AEDT

Update

We are aware of an issue that is impacting some customers' reporting on the Tyro Portal and on EFTPOS machines. The Tyro App appears to be unaffected. The team are working to resolve this issue as quickly as possible, and we'll continue to provide updates on our progress.
Posted Apr 05, 2025 - 17:33 AEDT

Identified

A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Apr 05, 2025 - 15:31 AEDT
This incident affected: Reconciliation & Settlement Reports.