Tyro Service Status

Settlement delay - Tyro Bank Account only
Incident Report for Tyro Service Status for Customers
Resolved
This issue has now been resolved. All settlements from the Tyro Bank Account have been processed.

We’re sorry for any inconvenience caused.
Posted Mar 17, 2020 - 20:26 AEDT
Identified
An issue has been identified where settlement from the Tyro Bank Account will be delayed. We are currently investigating this issue and will provide updates to this page.
We’re sorry for any inconvenience being experienced.
Posted Mar 17, 2020 - 19:44 AEDT
This incident affected: Settlement.