Tyro Service Status

Issue processing some transactions
Incident Report for Tyro Service Status for Customers
Resolved
This incident has now been resolved.
Posted Nov 09, 2019 - 12:41 AEDT
Monitoring
Some customers may have experienced a small increase in declined AMEX transactions earlier this morning.

Whilst this issue is now resolved, we are closely monitoring our transaction processing to ensure no further impact occurs.

We're sorry for any inconvenience that was experienced.
Posted Nov 09, 2019 - 11:34 AEDT
Investigating
We are currently experiencing issues which may affect the ability to process transactions.

We're in the process of investigating and will provide further updates shortly.

In the meantime, please try an alternative payment method.
Posted Nov 09, 2019 - 10:53 AEDT
This incident affected: Transaction Processing Systems.