Tyro Service Status

System issue with Tyro App
Incident Report for Tyro Service Status for Customers
Resolved
This issue has now been resolved.
Posted May 12, 2020 - 17:38 AEST
Monitoring
A fix has been implemented for this issue and we are currently monitoring the results. We will continue to provide updates as they become available.
Posted May 12, 2020 - 11:24 AEST
Identified
An issue has been identified with the Tyro App and may impact your ability to view Loans and connect to Xero.
We are looking into this issue and will provide updates as they become available. We’re sorry for any inconvenience caused.
Posted May 11, 2020 - 23:39 AEST
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted May 11, 2020 - 22:45 AEST
This incident affected: Tyro App.