Tyro Service Status

Potential settlement delay
Incident Report for Tyro Service Status for Customers
Resolved
This issue is now resolved.

We’re sorry for any inconvenience caused to our customers.
Posted Mar 18, 2020 - 14:18 AEDT
Monitoring
An issue been identified which is impacting customers of another financial institution and has resulted in delayed settlement for some of their customers. Please note this does not affect all financial institutions and is outside of Tyro’s control. We will continue to monitor the situation and provide updates on this page as they become available.

We’re sorry for any inconvenience caused.
Posted Mar 17, 2020 - 16:30 AEDT
Update
We are aware some customers are experiencing delays with their settlement and we are currently investigating. We will provide further updates on this page as they become available.

We apologise for any inconvenience being experienced.
Posted Mar 17, 2020 - 13:05 AEDT
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Mar 17, 2020 - 12:29 AEDT
This incident affected: Settlement.