Tyro Service Status

Tyro Pro transaction processing

Incident Report for Tyro Platform Service

Resolved

This incident has been resolved with transactions restored on Tyro Pro EFTPOS machines. We apologise for any inconvenience caused.
Posted Jul 15, 2025 - 16:23 AEST

Investigating

We’re currently experiencing an issue impacting some customers’ ability to process transactions on a Tyro Pro machine.

The team are looking into this urgently and will provide further updates as soon as possible. We’re sorry for any inconvenience being experienced.
Posted Jul 15, 2025 - 15:11 AEST
This incident affected: Transaction Processing Systems.