Tyro Service Status

Issues with access to invoices in Tyro Portal
Incident Report for Tyro Platform Service
Resolved
The issue impacting access to invoices in the Tyro Portal is now resolved and our systems have returned to normal.

We’re very sorry for any inconvenience caused.
Posted Jan 06, 2023 - 14:19 AEDT
Update
We’re currently experiencing an issue impacting some customers’ ability to access invoices in the Tyro Portal.

The team are working to resolve this issue as quickly as possible, and we’ll continue to provide updates on our progress.

We’re sorry for any inconvenience being experienced
Posted Jan 06, 2023 - 13:58 AEDT
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jan 06, 2023 - 13:41 AEDT
This incident affected: Tyro Portal.