Tyro Service Status

Tyro Pro Activation
Incident Report for Tyro Platform Service
Resolved
Good morning. We're pleased to confirm that Tyro Pro activation functionality is available again. Our Customer Support team is here on 1300 00 TYRO if you require any assistance during the self service activation experience.
Posted May 02, 2024 - 08:55 AEST
Identified
We are aware that the Tyro Pro activation functionality is currently unavailable. The team is working on a resolution and we'll provide an update here when this is available again. We apologise for any inconvenience caused.
Posted May 01, 2024 - 16:36 AEST