Tyro Service Status

Transaction reporting on Tyro Portal and EFTPOS machines (continued)

Incident Report for Tyro Platform Service

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 14:07 AEST

Identified

Following an issue identified with our systems over the weekend, some merchants may see a discrepancy between their eftpos and e-Commerce transactions and settlement reporting for Friday 1 August and/or Sunday 3 August,2025. We are working to rectify this as a matter of urgency.

Please check the Tyro App to view all transactions. We apologise for any inconvenience caused
Posted Aug 05, 2025 - 13:28 AEST
This incident affected: Tyro Portal.