Tyro Service Status

Issue processing some transactions
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.
Posted Nov 07, 2019 - 22:09 AEDT
Update
This incident has been resolved.
Posted Nov 07, 2019 - 22:01 AEDT
Investigating
We are currently experiencing issues which may affect the ability to process transactions.

We're in the process of investigating and will provide further updates shortly.

In the meantime, please try an alternative payment method.
Posted Nov 07, 2019 - 20:35 AEDT
This incident affected: Transaction Processing Systems.