Tyro Service Status

Transaction processing

Incident Report for Tyro Platform Service

Resolved

This incident has now been resolved.

We're sorry for any inconvenience experienced.
Posted Apr 21, 2026 - 14:34 AEST

Monitoring

We’re aware of an issue that was impacting some customers’ ability to process eftpos transactions. We are currently monitoring the situation, so if customers continue to have issues please ask them to use an alternative card.

Whilst the issue was outside Tyro’s control, we’re sorry for any inconvenience experienced
Posted Apr 21, 2026 - 08:46 AEST
This incident affected: Transaction Processing Systems.