Tyro Service Status

Delay with some Tyro Bank Account transfers

Incident Report for Tyro Platform Service

Resolved

The issue causing delays with transfers has now been resolved and all transfers have been processed. We apologise for any inconvenience experienced.
Posted Mar 16, 2026 - 17:39 AEDT

Update

We’re aware that some transfers out of the Tyro Bank Account are delayed. This includes settlement allocation from the Tyro Bank Account. We are investigating this as a priority and will provide updates when they become available. We apologise for any inconvenience.
Posted Mar 16, 2026 - 11:09 AEDT

Investigating

We are currently investigating this issue.
Posted Mar 16, 2026 - 10:23 AEDT
This incident affected: Tyro App.