Tyro Service Status

Settlement to Bendigo BSB accounts
Incident Report for Tyro Platform Service
Resolved
The issue impacting Tyro’s settlement to Bendigo BSB accounts has now been resolved. This payment may appear at varying times today.

We apologise for any inconvenience experienced.
Posted Sep 30, 2022 - 09:54 AEST
Identified
We’ve identified an issue with Tyro's settlement to Bendigo BSB accounts. The team are looking into this urgently and will provide further updates as soon as possible.

We’re sorry for any inconvenience being experienced.
Posted Sep 30, 2022 - 08:34 AEST
This incident affected: Settlement.