Tyro Service Status

Issues with Tyro App password resets
Incident Report for Tyro Platform Service
Resolved
The issue with Tyro App password resets has been resolved. We’re sorry for any inconvenience caused.
Posted Jul 15, 2023 - 08:14 AEST
Identified
We’re currently experiencing an issue impacting customers’ ability to reset Tyro App passwords.

As a workaround, you can reset your password through the Tyro Portal and then use these details to log into the Tyro App. Steps on how to do this can be found here - https://help.tyro.com/s/article/How-to-reset-the-Tyro-Portal-password.

We’re sorry for any inconvenience being experienced.
Posted Jul 14, 2023 - 19:54 AEST
This incident affected: Tyro App.