Tyro Service Status

Partial settlement notice
Incident Report for Tyro Platform Service
Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 11:00 AEDT
Monitoring
For those customers who received a partial settlement today, we can confirm that the remaining Mastercard Domestic funds have been successfully processed. This payment may appear at varying times depending on your banking provider. Once again we apologise for any inconvenience caused.
Posted Nov 08, 2023 - 18:44 AEDT
Identified
Please note that some customers will receive a partial settlement today with Mastercard Domestic transactions excluded. We will confirm later today when those remaining funds will appear in your account.

Whilst this delay was out of our control, we are working hard on resolving this for you and apologise for any inconvenience experienced.
Posted Nov 08, 2023 - 16:25 AEDT
This incident affected: Settlement.