Tyro Service Status

Possible delays with Settlement
Incident Report for Tyro Platform Service
Resolved
This incident has been resolved.
Posted Dec 07, 2024 - 09:05 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 06, 2024 - 15:33 AEDT
Identified
Please note that some customers may experience a few hours delay to their settlement payment today, this is out of tyro's control. This payment may appear at varying times depending on your banking provider.

We apologise for any inconvenience experienced.
Posted Dec 06, 2024 - 15:12 AEDT
This incident affected: Settlement.