Tyro Service Status

Tyro Bank Account - settlement delay
Incident Report for Tyro Platform Service
Resolved
All Tyro Bank Account customers have now had their settlement processed. We apologise for the delay experienced.
Posted Jan 02, 2025 - 12:09 AEDT
Update
We're aware that there has been a delay to Tyro Bank Account settlements for 2 January. We're investigating this as a priority and will provide updates here. We apologise for any inconvenience experienced.
Posted Jan 02, 2025 - 10:22 AEDT
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Jan 02, 2025 - 09:49 AEDT
This incident affected: Settlement.