Tyro Service Status

Possible system issues
Incident Report for Tyro Service Status for Customers
Resolved
The earlier issue is now resolve and all our systems have returned to normal. We're sorry for any inconvenience caused to you and your customers.
Posted Apr 17, 2022 - 22:24 AEST
Monitoring
We are investigating a potential issue that may be impacting some customers ability to connect and therefore process transactions.
Posted Apr 17, 2022 - 21:40 AEST
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Apr 17, 2022 - 21:16 AEST
This incident affected: EFTPOS machine connectivity.