Tyro Service Status

Medicare claiming
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.
Posted Mar 16, 2022 - 17:32 AEDT
Monitoring
We’re aware that Medicare is currently experiencing issues, which may be affecting their claims from being processed.

While this issue is outside Tyro's control, we’re actively monitoring the situation and will provide updates as they become available. If urgent, please contact Medicare directly.
Posted Mar 16, 2022 - 11:10 AEDT
This incident affected: Medicare Easyclaim.