Tyro Service Status

Issue with Tyro App
Incident Report for Tyro Service Status for Customers
Resolved
Update – All customers should now be able to access the Tyro App. If you still are unable to access the app please update your Tyro App version to iOS 5.3.1 or higher to resolve the issue. If you need assistance reach out to our 24/7 Customer Support team on 1300 TYRO.

We’re sorry for the inconvenience caused.
Posted May 04, 2022 - 10:22 AEST
Update
Update – The team is continuing to investigate why a small group of customers are experiencing difficulties accessing the Tyro App. If you are unable to log in, please call our Australian-based 24/7 Customer Support team on 1300 00 TYRO to discuss this in more detail. We’re sorry for any inconvenience being experienced.
Posted May 02, 2022 - 18:30 AEST
Update
We’re currently experiencing an issue impacting some customers’ ability to access the Tyro App.

The team are working to resolve this issue as quickly as possible, and we’ll continue to provide updates on our progress.
Posted May 02, 2022 - 11:34 AEST
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted May 02, 2022 - 11:18 AEST
This incident affected: Tyro App.