Tyro Service Status

Intermittent issues processing Medicare claims
Incident Report for Tyro Service Status for Customers
Resolved
This issue is now resolved, and our systems have returned to normal. We’re sorry for any inconvenience caused to you and your customers.
Posted Mar 10, 2022 - 10:56 AEDT
Monitoring
We’re aware that Medicare is currently experiencing issues, which may be affecting your ability to process claims via the Medicare Easyclaim system.

While this issue is outside Tyro's control, we’re actively monitoring the situation and will provide updates as they become available. Medicare have advised, if you experience an error, please retry the claim process. If urgent, please contact Medicare directly.
Posted Mar 08, 2022 - 12:51 AEDT
This incident affected: Medicare Easyclaim.