Tyro Service Status

HealthPoint
Incident Report for Tyro Platform Service
Resolved
We're pleased to confirm that health fund claims are now being processed again.
Posted Apr 03, 2024 - 15:45 AEDT
Monitoring
We’re aware that HealthPoint is currently experiencing issues, which is impacting health fund claims from being processed.

While this issue is outside Tyro's control, we’re actively monitoring the situation and will provide updates as they become available.

We’re sorry for any inconvenience being experienced.
Posted Apr 03, 2024 - 15:20 AEDT
Identified
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Apr 03, 2024 - 14:52 AEDT
This incident affected: Healthpoint.