Tyro Service Status

Settlement delay
Incident Report for Tyro Service Status for Customers
Resolved
This incident has been resolved.

We apologise for any inconvenience experienced.
Posted Oct 22, 2021 - 17:21 AEDT
Monitoring
Please note that some customers may experience a few hours delay to their settlement payment today. This payment may appear at varying times depending on your banking provider.

We apologise for any inconvenience experienced.
Posted Oct 22, 2021 - 14:52 AEDT
This incident affected: Settlement.