Tyro Service Status

Loans tab on Tyro App
Incident Report for Tyro Platform Service
Resolved
This issue is now resolved.

We’re sorry for any inconvenience caused to our customers.
Posted Aug 01, 2020 - 14:13 AEST
Monitoring
The loans tab was recently unavailable on the Tyro App for a short period of time.

We’re sorry for any inconvenience caused to our customers.
Posted Aug 01, 2020 - 14:03 AEST
Investigating
A possible issue has been identified with our systems. We are currently investigating. Further updates will follow shortly.
Posted Aug 01, 2020 - 13:42 AEST
This incident affected: Tyro App.